HS Uploader

Fragen, Anregungen zur PC-Wetterstations-Software

Moderatoren: weneu, Tex, Werner

loaecker
Beiträge: 243
Registriert: 26 Okt 2014 11:34

HS Uploader

Beitrag von loaecker »

Hallo zusammen,

bin gerade dabei mit Wswin auf einen neuen Rechner umzuziehen. Um die Dateien auf die Webseite hochzuladen, verwende ich seit Jahren den HS-Uploader. Die Einstellungen werden ja in einer ini Datei abgespeichert, die ich jetzt auf meinem alten PC nicht mehr finde. Ich kann auch das automatische hochladen nicht abbrechen um in die Enstellungen zu gelangen. Seltsam nur, dass das Hochladen der Dateien trotzdem funktioniert, obwohl die ini Datei fehlt. Meine Frage ist nun: Gibt es irgendwo im Netz eine Anleitung, wie ich die Einstellungen bei HS Upload vornehmen muss. In den einschlägigen Foren habe ich nichts gefunden. Und auf der Homepage von Herbert Schneider wird auch der Download der Software nicht mehr angeboten. Das ist leider schon etliche Jahre her. Und ich gerade ein bisschen auf dem Schlauch stehe, was neben den FTP Einstellungen eingegeben werden muss.
Benutzeravatar
gargamel
Beiträge: 483
Registriert: 13 Mär 2009 18:35
Wohnort: 41334 Nettetal-Kaldenkirchen
Kontaktdaten:

Beitrag von gargamel »

Hallo loaker,
suche mal in windows registry nach der ini datei.
Download HsUpload hier:
https://www.pc-wetterstation.de/scripte/FTP-Programme/
Grüße aus
Nettetal - Kaldenkirchen
Wilfried

Mitglied beim www.ruhrwetter.de

www.wilfried-monika.de

Davis VantagePro2 Active Plus, Wetterdirekt Sirius 300 und Sturmglas, TOA-Blitzortung, Radioaktivmessung
Benutzeravatar
Tex
Moderator
Beiträge: 1452
Registriert: 04 Aug 2014 17:47
Wohnort: Woldegk
Hat sich bedankt: 1 mal
Kontaktdaten:

Beitrag von Tex »

Hallo Lothar,

versuch mal folgendes:

Internetverbinden kappen, HS-upload händisch starten und dann in die Einstellungen gehen:

>Zeit für Abbruch nach Programmstart (Sekunden) > gib hier eine 9 ein. Dann hast Du immer 9 Sekunden lang Zeit die Übertragung zu stoppen. Vermutlich steht da nix drin oder eine 0, weshalb ein Abbruch unmöglich ist.
Benutzeravatar
weneu
Site Admin
Beiträge: 11355
Registriert: 22 Feb 2002 01:00
Wohnort: Donauwörth
Kontaktdaten:

Beitrag von weneu »

Hallo,
Du findest die hsupload.ini normalerweise im Verzeichnis
c:\users\benutzer\Appdata\roaming\HSUpload
wobei "benutzer" Dein Benutzername auf dem PC ist
Benutzeravatar
Tex
Moderator
Beiträge: 1452
Registriert: 04 Aug 2014 17:47
Wohnort: Woldegk
Hat sich bedankt: 1 mal
Kontaktdaten:

Beitrag von Tex »

Auszug aus der HS-Uploadbeschreibung:
Speicherort der Einstellungen:

Seit der Version 1.40 werden alle Einstellungen, Projekte und Logdateien im Unterverzeichnis HSUpload in den Anwendungsdaten, welches sich normalerweise unter
C:\Dokumente und Einstellungen\Username\Anwendungsdaten befindet, gespeichert.

Dort liegt bei mir ein Ordner mit HS-Upoad, wo auch die inis drin sind.
Benutzeravatar
weneu
Site Admin
Beiträge: 11355
Registriert: 22 Feb 2002 01:00
Wohnort: Donauwörth
Kontaktdaten:

Beitrag von weneu »

Hallo Tex,
der Speicherort hängt von der jeweiligen Windows-Version ab, deshalb habe ich auch geschrieben: normalerweise
Bei Windows10 in der Version 1803 ist es der von mir genannte Speicherort.
Da gibt es auch keinen Ordner "Dokumente und Einstellungen" mehr, sondern nur noch einen Ordner "Dokumente", der aber anderen Dingen vorbehalten ist.
Ferner hängt es davon ab, ob man in Windows lokal angemeldet ist oder bei seinem Microsoft-Account. Es ist also etwas kompliziert.
Denn in dem Fall ist der Ordner "Dokumente" ein Unterordner von "OneDrive"
Aber das wird der Fragesteller ja nun an Hand unserer Aussagen selbst herausfinden, wo es sich bei ihm tatsächlich befindet.
loaecker
Beiträge: 243
Registriert: 26 Okt 2014 11:34

Beitrag von loaecker »

Zunächst mal vielen Dank für eure Antworten und Vorschläge. Leider habe ich die Ini Datei nicht gefunden, so dass ich HS Upload neu installiert und mich durchgekämpft habe, bis ich die Einstellungen so weit hatte, dass der automatische upload wieder funktioniert. Nur hat sich aus irgendeinen Grund HS Upload nach einigen Stunden aufgehängt. Das Programm habe ich dann über den Task-Manager schließen müssen. Nach einem Neustart ging´s wieder. Allerdings klappt jetzt das Abbrechen des automatischen Hochladens nicht mehr um in die Einstellungen zu gelangen. Es lässt sich mit dem Mauszeiger nirgendwo anklicken. Ich bin mir nicht sicher, ob ich einen Fehler bei den Einstellungen begangen habe. :roll:
Benutzeravatar
Tex
Moderator
Beiträge: 1452
Registriert: 04 Aug 2014 17:47
Wohnort: Woldegk
Hat sich bedankt: 1 mal
Kontaktdaten:

Beitrag von Tex »

Wenn mein Vorschlag von oben nicht klappt, direkt in die inis gehen und die Einstellung verändern, gleich ganz oben:

Abbruch-Zeit=9
loaecker
Beiträge: 243
Registriert: 26 Okt 2014 11:34

Beitrag von loaecker »

Tex das funktioniert nicht, da ich die ini Datei auch nach der Neuinstallation nicht finden kann. Es gibt bei mir den Speicherort c:\users\benutzer\Appdata\roaming\HSUpload nicht.
Benutzeravatar
weneu
Site Admin
Beiträge: 11355
Registriert: 22 Feb 2002 01:00
Wohnort: Donauwörth
Kontaktdaten:

Beitrag von weneu »

Hallo Lothar,
was hast Du denn für eine Windows-Version?
Zusätzlich vermute ich, dass Du hier eine Einstellung hast, die nicht alle Ordner anzeigt.
Rufe den Dateiexplorer auf, gehe zu Ansicht - Optionen und dort ebenfalls zum Reiter "Ansicht" und wähle dort "Ausgeblendete Dateien, Ordner und Laufwerke anzeigen"
Dann sollte der von mir genannte Pfad sichtbar sein und Du solltest auch mit der Suchfunktion die hsupload.ini finden.
Benutzeravatar
Tex
Moderator
Beiträge: 1452
Registriert: 04 Aug 2014 17:47
Wohnort: Woldegk
Hat sich bedankt: 1 mal
Kontaktdaten:

Beitrag von Tex »

Dann starte einen Suchlauf nach HSupload.
Benutzeravatar
weneu
Site Admin
Beiträge: 11355
Registriert: 22 Feb 2002 01:00
Wohnort: Donauwörth
Kontaktdaten:

Beitrag von weneu »

Hallo Tex,
hat sich mit meiner Bemerkung wahrscheinlich überschnitten. Wenn meine Vermutung stimmt, wird auch der Suchlauf nichts helfen, denn dann ist der Ordner ausgeblendet und wird in die Suche nicht einbezogen.
Das ist ein leidiges Problem mit den Standardeinstellungen von Windows, ähnlich dem Unfug, bei "bekannten Dateien" die Endung auszublenden.
Da kann man dann mit einer Datei
liedasmal.pdf.exe
dem User ein Schadprogramm unterjubeln, weuil ermeint, es sei eine pdf-Datei und in Wirklichkeit ist es eine exe-Datei. Aber das ist ein anderes Thema.
loaecker
Beiträge: 243
Registriert: 26 Okt 2014 11:34

Beitrag von loaecker »

Hallo Werner,
ich habe Windows 10. Habe die Dateierweiterungen zugelassen (waren deaktiviert) habe hsupload.ini in die Suchleiste eingegeben. Leider ohne Erfolg. Datei wurde nciht gefunden.
Benutzeravatar
Tex
Moderator
Beiträge: 1452
Registriert: 04 Aug 2014 17:47
Wohnort: Woldegk
Hat sich bedankt: 1 mal
Kontaktdaten:

Beitrag von Tex »

und wähle dort "Ausgeblendete Dateien, Ordner und Laufwerke anzeigen"
Hast Du das auch gemacht?
Benutzeravatar
Tex
Moderator
Beiträge: 1452
Registriert: 04 Aug 2014 17:47
Wohnort: Woldegk
Hat sich bedankt: 1 mal
Kontaktdaten:

Beitrag von Tex »

...gehe zu Ansicht - Optionen und dort ebenfalls zum Reiter "Ansicht" und wähle dort "Ausgeblendete Dateien, Ordner und Laufwerke anzeigen"
Hast Du das auch gemacht?
Antworten